How can I use Illustrator to draw my glyphs? How can I import glyphs from EPS files?


If you intend to use Adobe Illustrator to draw the glyph outlines:

In Illustrator, go to Edit > Preferences > Units & Undo or Units & Display Performance. Change all units to points (1 point is equal to 1 unit in FontLab). Go to Preferences > Files & Clipboard.

Disable PDF, enable AICB and select Preserve Paths. In Preferences > Guides & Grid, set Gridline every: 10 pt and Subdivisions.

Still in Illustrator, select File > New. Set the width of the document in points to be the double of the UPM size of your font (e.g. 2000 pt for a 1000 UPM font). Set the height of the document to be the same as UPM size – Descender (e.g. 1000 – (–263) = 1263 pt). Select Window > Info, View > Show Rulers, View > Snap to Grid. Disable View > Guides > Lock Guides.

Optionally select View > Show Grid. Now click on the top ruler of the Illustrator document window and drag out a guideline. Position it at the height that has the same (positive) value as the (negative) descender of your font (e.g. 263 in our example).

From the left ruler, drag a guideline and position it at 0. Click at the top left corner of the Illustrator document window (where the top ruler and the left ruler meet) and drag out the origin point to where the two guidelines you have just drawn cross. Finally, click on the top ruler and drag guidelines to the positions of your ascender, x-height, and caps height. You can draw your letters.

Remember to assign some kind of fill to all your Illustrator drawings and avoid drawing letters that exceed the bottom or the top of the document size. If you have already drawn some letters before, copy them to the newly created document, place and re-scale so that they fit between the guidelines you've drawn.

Remember that all points of your letters should snap to the grid (otherwise FontLab will round their position). When you have finished drawing your glyph in Illustrator, choose Select > All, Edit > Copy if you want to copy the outlines via clipboard or File > Export > Illustrator Legacy EPS or File > Save As, and select Illustrator 8 EPS as your file format, if you want to save the artwork as an EPS file.

Importing Glyphs To paste an outline from a vector-editing program into FontLab Studio select the outline object that you want to copy and choose the Copy command from the Edit menu (in the source application). To place the copied outline in FontLab Studio switch to FontLab Studio (Glyph Window) and select the Paste command from the Edit menu. To import an Illustrator 8-compatible EPS file into FontLab Studio, open a Glyph window (make a new glyph if necessary) and choose Edit > Paste.